DMVPN Phase 2 Hub & Spoke – EIGRP example

    DMVPN Phase 2 Hub & Spoke – EIGRP example


    Traffic Flow:

    • Packet is intended to be sent from Spoke1 to Spoke2 network
    • According to routing table Spoke’s2 network is known via its original next hop but it is marked in CEF as incomplete and next hop IP is marked simultaneously as CEF glean adjacency / punt (now, need to perform NHRP resolution) – the NBMA of next hop is unknown, so Spoke1 triggers NHRP resolution to NHS (including next hop of Spoke2, Source of its tunnel, it’s NBMA)
    • In the same time first packet is routed via Hub based on RIB
    • Similar thing is done by Spoke2 when it needs to send packet back to Spoke1
    • NHS (Next hub self ) responds with NHRP resolution and then CEF is populated as complete and Spokes can communicate directly

     

    DMVPN Phase 2 and EIGRP

    • Advertise spoke’s connected routes
    • Disable split horizon on hub (Spoke to Spoke prefix advertisement)
    • Disable Next hop self feature

     

    Hub:

    conf t

    !

    router eigrp 100
    network 20.1.1.0 0.0.0.255
    network 172.16.1.0 0.0.0.255
    !
    interface Tunnel0
    ip address 172.16.1.1 255.255.255.0
    no ip redirects
    no ip next-hop-self eigrp 100
    ip nhrp authentication AVIU@OLU
    ip nhrp map multicast dynamic
    ip nhrp network-id 111
    no ip split-horizon eigrp 100
    no ip split-horizon
    tunnel source Loopback0
    tunnel mode gre multipoint
    tunnel key 123
    tunnel protection ipsec profile DMVPN_PROFILE

     

    Spoke A :

    conf t

    !

    router eigrp 100
    network 20.1.2.0 0.0.0.255
    network 172.16.1.0 0.0.0.255
    !
    interface Tunnel0
    tunnel mode gre multipoint

     

    Spoke B :

     conf t

    !

    router eigrp 100
    network 20.1.3.0 0.0.0.255
    network 172.16.1.0 0.0.0.255
    !
    interface Tunnel0
    tunnel mode gre multipoint

     

    NOTE :  The tunnel destination command need to be removed because of mGRE behavior: